Hướng dẫn cấu hình cơ bản Router Cisco Packet Tracer

0
9690
huong dan cau hinh router cisco paket tracer anh 1

Các lệnh cấu hình Router Cisco Packet Tracer cơ bản, switch. Cách kết nối 2 router tp-link internet. Cấu hình định tuyến tĩnh, gán địa chỉ IP, subnet mask . . . tự học CCNA.

1.Cấu hình router là gì?

Cấu hình Router, các lệnh cấu hình Router, Switch trong Cisco Packet Tracer là sử dụng các mã lệnh trong CLI (Comand Line Interface) để thiết lập các thông số cho router.
Các thông số như tên, pass, địa chỉ ip, . . .

Cấu hình Router switch Cisco là bài tập cơ bản phải nắm được cho các bạn tự học, ôn luyện thi chứng chỉ CCNA hoặc làm bài tập môn Mạng Máy Tính tại các trường đại học chuyên ngành Công Nghệ Thông Tin.

huong dan cau hinh router cisco paket tracer anh 2

2.Hướng dẫn toàn bộ cấu hình router

Cấu hình Router Cisco Packet Tracer gồm có hai phần:

  1. Cấu hình các thông số cơ bản bao gồm: Tên Router, mật khẩu, khởi động các cổng fa, se, banner motd, gán địa chỉ ip cho các cổng . . .
  2. Cấu hình định tuyến tĩnh cho Router: Phần này giúp cho router kết nối được với các mạng khác.

Khi hoàn thành hai phần trên, thì bạn đã cấu hình cho router, switch thành công. Bạn có thể ping xanh từ máy tính, laptop, pc này sang pc khác ngoài mạng lan.

Bài tập ví dụ

2.1 Cấu hình các thông số cơ bản cho router

Để cấu hình được các thông số cho Router, chúng ta cần sử dụng các câu lệnh trong CLI. Bạn cần khởi động giao diện CLI của Router lên và sử dụng lần lượt các lệnh theo thứ tự các bước liệt kê dưới đây.

Bước 1: Bạn cần mở CLI lên và vào mode của chế độ đặc quyền và vào mode cấu hình.

Chú ý: sau mỗi dòng lệnh bạn nhấn ENTER nhé!
Mẹo: Bạn chỉ cần nhập vài chữ đầu sau đó nhấn tab câu lệnh sẽ tự hoàn thiện!

Cú pháp:
enable
configuer terminal

Router>enable
Router#configure terminal
Router(config)#

Bước 2: Đặt tên cho router và đặt mật khẩu
Các loại mật khẩu Line console và mật khẩu vty

Cú pháp:
hostname + Tên
enable secret + mật khẩu //Tạo mật khẩu cho router
line console 0
password + mật khẩu // tạo mật khẩu cổng console
login
exit
line vty 0 4 // tạo mật khẩu cổng vty từ 0 đến 4
password + mật khẩu
exit
banner motd @ghi chu@ // thêm ghi chú cho router mỗi khi bạn đăng nhập

Router(config)#hostname R1
R1(config)#enable secret matkhau
R1(config)#line console 0
R1(config-line)#password matkhau
R1(config-line)#login
R1(config-line)#exit
R1(config)#line vty 0 4
R1(config-line)#password matkhau
R1(config-line)#exit
R1(config)#banner motd @Nhap mat khau de dang nhap@

Bước 3: Khởi động các cổng Fa và Se gán địa chỉ IP theo yêu cầu của bài.

Chú ý: Bạn cần phải cấu hình toàn bộ các cổng nếu có!

Cú pháp:
Cấu hình cổng Fa:
interface Fastethernet + tên cổng
no shutdown
ip address + địa chỉ ip + Subnetmask
exit

Cấu hình cổng Se:
interface serial + Tên cổng
no shutdown
clock rate 56000 // câu lệnh này ở cổng nào có biểu tượng đồng hồ mới cần dùng
ip address + địa chỉ Ip + Subnetmask
exit

R1(config)#interface Fastethernet 0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 1.0.0.1 255.0.0.0
R1(config-if)#exit
R1(config)#interface serial 2/0
R1(config-if)#no shutdown
R1(config-if)#ip address 100.100.100.1 255.255.255.0
R1(config-if)#clock rate 56000
R1(config-if)#exit
huong dan cau hinh router cisco paket tracer anh 4
Bài tập ví dụ

2.2 Cấu hình định tuyến tĩnh cho Router

Sau khi cấu hình các thông số mặc định cho Router, để các máy tính khác mạng lan có thể kết nối được với nhau (ping được) bạn cần phài cấu hình định tuyến tĩnh cho router.

Ở đây bạn phải cho router định tuyến được những mạng không kết nối trực tiếp với nó. Như trong bài tập mình ví dụ thì ở router 1 cần định tuyến mạng 2.0.0.0 /8 qua cổng Se2/0. Router 2 cần phải định tuyến mạng 1.0.0.0 /8 qua cổng Se2/0,

Việc thực hiện vẫn ở trên CLI ở mode chế độ độc quyền.

Cú pháp:
ip route + địa chỉ IP + subnet mask + cổng kết nối

R1(config)#ip route 2.0.0.0 255.0.0.0 se2/0

Bạn cần phải cấu hình tất cả các mạng không kết nối trực tiếp với router. Số lượng tùy để bài.

Chú ý: Sau khi thực hiện cấu hình xong, bạn cần phải lưu lại file cấu hình trước khi thoát ở chế độ bình thường.

Cú pháp: wr
hoặc: copy running-config startup-config

R1#copy running-config startup-config 
Destination filename [startup-config]? 
Building configuration...
[OK]
//hoặc:
R1#wr
Building configuration...
[OK]


Hết bước này, các máy tính trong hệ thống có thể kết nối internet được với nhau (ping thành công). Với điều kiện bạn đã cấu hình tất cả các Router trong mạng.

Thực hiện các thao tác lần lượt như trên. Bạn đã giải thành công một bài tập môn mạng máy tính, bài tập ôn thi CCNA cơ bản nhất!

huong dan cau hinh router cisco paket tracer anh 5
Bài tập ví dụ

Cách cấu hình router tp-link, cấu hình wifi sẽ chia sẻ ở các bài viết sau

3. Hướng dẫn tính địa chỉ Subnet Mask

Phần này mình sẽ hướng dẫn bạn cách tính địa chỉ Subnet Mask.

Một địa chỉ Subnet Mask gồm có 32 bit nhị phân. Khi đổi thành hệ thập phân tương ứng với 8 bit một số thập phân.

Bạn thường thấy các địa chỉ /8 /9 /11 /24 /26 . . . Vậy đổi thành thập phân như thế nào?
Về bản chất, số subnet mask ở đây chính là số bit 1 trên tổng số 32 bit từ trái qua phải, còn lại là bit 0. Cứ 8 bit liền nhau sẽ đổi thành một số ở hệ thập phân. Từ đó tính ra Subnet mask hệ thập phân.

Ví dụ 1: /8
Hệ nhị phân: 8 bit 1 + 24 bit 0 :
Hệ thập phân: 255.0.0.0

Ví dụ 2: /26
Hệ nhị phân: 26 bit 1 + 6 bit 0
Hệ thập phân: 255.255.255.192

Mẹo tính hay: lấy số SM chia cho 8 được XN.
X sẽ là số lượng số bộ 8 bit 1 tương ứng với số lần số 255. N là số bit 1 dư cần phải đổi.

Đem n tính như sau:
n=1: 128
n=2: 128+64 =192
n=3: 128+64+32 = 224
n=4: 128+64+32+16 = 240
n=5: 128+64+32+16 +8 = 248
n=6: 128+64+32+16 +8 +4 = 252
n=7: 128+64+32+16 +8 +4 +2 = 254
n=8: 128+64+32+16 +8 +4 +2 +1 = 255

Ví dụ 1 tính SM = /27
Lấy 27 chia 8 = 3 dư 4
==> có 3 lần số 255 và số 240
Kết quả: /27 = 255.255.255.240

Ví dụ 2: Tính SM = /11
11 chia 8 được 13.
Kết quả: /11 = 255.224.0.0
(số bộ 8 bit còn lại chuyển thành 0).

4. Các lệnh Cisco Packet Tracer thường dùng

Tổng hợp một số lệnh Cisco Packet Tracer thường dùng như sau:

Nhóm lệnh Show:
Chạy ở mode R#

  • show run : show đã chạy
  • show ip route: show địa chỉ ip định tuyến tĩnh
  • show interface: show thông số các cổng
  • show ip iterface brief : show địa chỉ IP các cổng

Nhóm lệnh kết thúc:

  • exit : Thoát một cấp độ mode
  • end: Thoát toàn bộ
  • ? + Lệnh : Hủy Lệnh đã thực hiện. (thêm dấu ? vào trước câu lệnh đã thực hiện muốn hủy )

Nhóm lệnh lưu file cấu hình:

  • copy running-cofig startup-config
  • wr: Lưu file cấu hình
  • enable: Khởi độn mode đặc quyền
  • configure terminal: Mode vào chế độ cấu hình

Ngoài ra bạn có thể tham khảo tổng hợp tất cả các lệnh trong Cisco Packet Tracer dùng với Router, Switch khác TẠI ĐÂY.

Tham khảo các thủ thuật IT, các bài chia sẻ lập trình, các bài chia sẻ về IT khác TẠI ĐÂY

Tham khảo video hướng dẫn:

Chúc bạn thành công!

HẾT

LEAVE A REPLY

Please enter your comment!
Please enter your name here